Re: Time Services

This topic contains 19 replies, has 2 voices, and was last updated by Avatar of BillDen BillDen 3 years, 2 months ago.

Viewing 10 posts - 1 through 10 (of 20 total)
Author Posts
Author Posts
January 18, 2011 at 7:46 pm #86310
Avatar of BillDen
BillDen
Member

I have read all I can find regarding the Windows 7 time service and nothing answers my specific question.  So, here it is:

I am running Windows 7 on a standard desktop PC.  On that PC, I am running a very simple software VoIP server (miniSipServer) and have 4 VoIP phones (Snom320) connected.  The phones allow me to point to a time server so that all the phones display the same time.  I originally had this running on an XP box and it was extremely simple.  I only had to ensure that the time service was running and all was good.  I then moved to a Windows 7 box.  I could not get the time to run no matter what I tried.  A coworker read a lot on the web and made a bunch of changes but nothing seemed to work.  Suddenly, it started to work on the Windows 7 box but he wasn’t sure which series of changes finally fixed it.  Anyway, we had to reload a clean version of Windows 7 on the PC and we again cannot get the time to work.  So far we have tried to turn off the firewall, ensure the time services were running, manually stopped and restarted the time services, etc.  You name it, we probably tried it.  Currently I had to throw an XP laptop into the network just so the phones could grab time from it.

What are the exact steps to get the time services running on Windows 7? I know it can work because it was working before we reloaded Windows 7.

By the way, this is a totally standalone classroom network that has no outside connectivity whatsoever.

January 18, 2011 at 8:18 pm #89838
Avatar of W7NOmoronovo
W7NOmoronovo
Member

How do the phones actually try to get the time from the computer? Are they trying to use SNTP?

January 18, 2011 at 8:25 pm #89839
Avatar of W7NOmoronovo
W7NOmoronovo
Member

Assuming they AREN’T trying to use SNTP, I suggest you do the following:

1. Make sure the firewall is off, or that port 13 is open for devices in the Home/work network.

2. Enable Simple TCPIP services – to do this:
[list:1pfzrlkn]
[*:1pfzrlkn]Open up control panel > programs and features > click "turn windows features on or off" at the left.[/*:m:1pfzrlkn]
[*:1pfzrlkn]Find the entry for "Simple TCPIP services" and enable it.[/*:m:1pfzrlkn]
[*:1pfzrlkn]Restart your machine if it asks you to.[/*:m:1pfzrlkn][/list:u:1pfzrlkn]

Hopefully the phones are just sending a simple DAYTIME request to the machine, which is why it would work on XP by but not on windows 7 without modifications – these tools are rarely used and have been disabled by default since Windows Vista was released.

January 18, 2011 at 8:32 pm #89840
Avatar of BillDen
BillDen
Member

According to the Snom320 documentation, you point the phone to the IP address of a NTP (Network Time Protocol) server.  I know that all I had to do in XP was turn on the time services (I believe it was w32time).

January 18, 2011 at 8:40 pm #89841
Avatar of BillDen
BillDen
Member

I just saw your second post where you mentioned port 13.  I believe we had to open UDP port 123 in order for it to work before (or just turn off the firewall).  Did you mean to type 13 or did you mean 123.

January 18, 2011 at 9:28 pm #89842
Avatar of BillDen
BillDen
Member

Omoronovo,
I just checked and saw that that Simple TCPIP services was not turned on so I turned it on.  The firewall is OFF so I didn’t mess with port 13.  Unfortunately, it was still a no-go for the phones retrieving the time from the PC.

Thanks for the try.  Any other suggestions?

January 18, 2011 at 9:33 pm #89843
Avatar of W7NOmoronovo
W7NOmoronovo
Member

No, I meant port 13 – I was assuming your phones were NOT using NTP. Since they are, you need to actually set the time service to act as a server instead of just a client.

The easiest way to do this would be to stop the time service, run/merge this registry file I created (attached), and then start the time service again.

I have created two registry files: one (timeservon) will enable the service. The other (timeservoff) will revert the changes, should you wish them to be restored at a future date.

If you would prefer to do the registry change manually, or for future reference, you must make the following changes:
[list:3arqmjz3]
Open up Regedit.
[list:3arqmjz3][*:3arqmjz3]Navigate to HKLMSYSTEMCurrentControlSetServicesW32TimeConfig. Find the entry named AnnounceFlags and change it’s value from a(10) to 5(5).
[*:3arqmjz3]Now, navigate to HKLMSYSTEMCurrentControlSetServicesW32TimeTimeProvidersNtpServer. find the entry named Enabled and change it’s value from 0(0) to 1(1).[/*:m:3arqmjz3][/list:u:3arqmjz3]

After you restart the time service, it will act as a relay for any other computers or devices on the network to synchronize to. Just remember to make sure the computer clock remains accurate, or it will impact the time on all the phones as well.
[/*:m:3arqmjz3][/list:u:3arqmjz3]
Oh, and make sure that UDP port 123 is enabled on the inbound section of the firewall. If you need any help with these, let me know.

January 18, 2011 at 9:46 pm #89844
Avatar of W7NOmoronovo
W7NOmoronovo
Member

After you make this change, I would recommend that you re-disable the simple TCPIP services (most people have no use for them), and re-enable your firewall, remembering to open port 123 UDP.

January 19, 2011 at 2:34 pm #89845
Avatar of BillDen
BillDen
Member

BINGO!!!!!

That was the trick!  Thank you so much for your help!  I haven’t disabled the Simple TCPIP services yet or re-enabled the firewall but that’s the easy stuff.

Thanks Again!

January 19, 2011 at 3:01 pm #89846
Avatar of BillDen
BillDen
Member

Still have a nagging problem…

Whenever I reboot the Windows7 box, the Windows Time Service stops.  It is set for Automatic although the service did not start on reboot.  I have read a little about using the Automatic-Delay setting but that doesn’t make a whole lot sense.

As the official Expert, how do you recommend I configure the service (either by regedit or the Windows GUI) so that the service will start automatically on reboot.

Viewing 10 posts - 1 through 10 (of 20 total)

You must be logged in to reply to this topic.